[SciPy-user] timeseries import error

Matt Knox mattknox_ca@hotmail....
Thu Jan 24 17:32:43 CST 2008


> > timeseries is the scikits since a couple of days, thanks to Matt. This 
> > is the svn url:
> > 
> > http://svn.scipy.org/svn/scikits/trunk
> Does that mean that they will be automatically included in the scipy 
> binary builds in the near future?
> 
> I would like to have binaries for Windows and Ubuntu.

I won't be providing any binaries until there has been an official release of
numpy using the new version of the masked array module. I can't provide a
timeline for that because I am not really involved in that process. But keep
your eyes peeled for discussion on a numpy 1.0.5 release since that it is when
it is likely to happen from my understanding.

My intention is to provide windows binaries for Python 2.4 and 2.5 eventually.
Python 2.3 won't be supported because the timeseries module relies on features
of the datetime C api that were introduced in Python 2.4 (although if someone
felt that they could remove that dependency without making the code
significantly more complicated, I'd certainly be open to it).

As far as ubuntu binaries... I'm a die hard windows guy so I won't be of any
help here. It should be extremely simple to build on ubuntu though since linux
comes setup with compilers and there are no external dependencies for the
timeseries module outside of numpy and scipy itself (and scipy is only a run
time requirement, not needed for building it).

- Matt



More information about the SciPy-user mailing list