[SciPy-user] Installation on Intel OS X.5 leopard: libcc_dynamic problem

Robert Kern robert.kern@gmail....
Sun Jan 27 14:20:34 CST 2008


Ilmar Wilbers wrote:
> Robert Kern <robert.kern <at> gmail.com> writes:
> 
>> You cannot use g77 with Python universal binaries. You need to use 
>> gfortran, as 
>> mentioned on the web page. You can get a binary from here:
>>
>>    http://r.research.att.com/tools/
> 
>  wor
> Hi,
> 
> If I remove the -lcc_dynamic flag manually (edit the numpy.distutils 
> source code), I get this to work jut fine. 

Did you try to import a module with FORTRAN code? The problem that -lcc_dynamic 
solves only shows up then, not at build time.

> Isn't it possible to remove the lines
> 162-163 in numpy.distutils.fcompiler.gnu by using som flag?

No. -lcc_dynamic is required for gcc 3.x, the only versions of gcc which g77 
works with.

You cannot use these with a Universal binary of Python.

You need to use gfortran.

We need to find out why you managed to pick up g77 instead of gfortran when you 
specific --fcompiler=gnu95.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco


More information about the SciPy-user mailing list