[SciPy-user] odepack or f2py error

Fabrice Silva silva@lma.cnrs-mrs...
Sat Jul 12 06:32:29 CDT 2008


Le jeudi 10 juillet 2008 à 19:30 +0000, Pauli Virtanen a écrit :
> What Fortran compiler are you using? Some old version of gfortran
> perhaps?

I do have gfortran installed

        fab@Portable-s2m:~$ gfortran --version
        GNU Fortran (Debian 4.3.1-6) 4.3.1

How can I check gfortran is used by f2py ?

> I think this "Internal Error:" message is from your Fortran compiler. 
> Googling for it brings up several messages referring to gfortran, so
> it's likely this is a gfortran bug (possibly fixed in newer versions).

I am using debian unstable, by weekly upgrade. I remember using printf
calls for debugging last year without any error.
I have looked at the gfortran bugzilla, but I did not see any bugs which
seems similar to this one...
> 
-- 
Fabrice Silva <silva@lma.cnrs-mrs.fr>
LMA UPR CNRS 7051 - équipe S2M



More information about the SciPy-user mailing list