[SciPy-user] sparsetools involvement? (was -lf77compat build failure)

Nathan Bell wnbell@gmail....
Fri Jul 18 08:37:46 CDT 2008


On Thu, Jul 17, 2008 at 3:53 PM, Phil Forrest
<forrest@physics.auburn.edu> wrote:
>
> After reviewing the compilation failures, Robert Kern suggested I post the
> following error messages to this list. Again, the original problem has to do
> with no "f77 compatibility" library included with Sun Studio 12 (8.3) - at
> least on Sun Solaris x86. The lack of this library caused the scipy build to
> fail.
>
> Below is a portion of the error messages from building scipy with
> "f77compat" REMOVED from sun.py in the numpy tree/build.
>

Phil, could you try compiling SciPy from SVN?  Much of sparsetools has
changed since the last release.

I believe there was a missing #include <algorithm> in sparsetools.h in
the release you're using.

-- 
Nathan Bell wnbell@gmail.com
http://graphics.cs.uiuc.edu/~wnbell/


More information about the SciPy-user mailing list