[SciPy-user] "from scipy.linalg.flapack import dgelss" fails

Nils Wagner nwagner@iam.uni-stuttgart...
Sat Jun 7 10:11:10 CDT 2008


On Sat, 07 Jun 2008 17:58:55 +0300
  dmitrey <dmitrey.kroshko@scipy.org> wrote:
> I have problems with the statement
> from scipy.linalg.flapack import dgelss
> 
> Traceback (innermost last):
>  File "<stdin>", line 1, in <module>
>  File 
>"/usr/lib/python2.5/site-packages/scipy/linalg/__init__.py", 
>line 
> 13, in <module>
>    from iterative import *
>  File 
>"/usr/lib/python2.5/site-packages/scipy/linalg/iterative.py", 
> line 5, in <module>
>    from scipy.sparse.linalg import isolve
>  File 
>"/usr/lib/python2.5/site-packages/scipy/sparse/__init__.py", 
>line 
> 5, in <module>
>    from base import *
>  File 
>"/usr/lib/python2.5/site-packages/scipy/sparse/base.py", 
>line 45, 
> in <module>
>    class spmatrix(object):
>  File 
>"/usr/lib/python2.5/site-packages/scipy/sparse/base.py", 
>line 
> 139, in spmatrix
>    @deprecate
> TypeError: deprecate() takes exactly 3 arguments (1 
>given)
> 
> at least with latest scipy from svn
> 
> >>> scipy.__version__
> '0.7.0.dev4416'
> 
> Do you have the same?
> This one was working correctly in previous scipy 
>versions
> 
> Regards, D.
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user

No problem here

/usr/bin/python
Python 2.4 (#1, Oct 13 2006, 17:13:31)
[GCC 3.3.5 20050117 (prerelease) (SUSE Linux)] on linux2
Type "help", "copyright", "credits" or "license" for more 
information.
>>> from scipy.linalg.flapack import dgelss
>>> import scipy
>>> scipy.__version__
'0.7.0.dev4416'
>>> help (dgelss)
  


More information about the SciPy-user mailing list