[SciPy-user] scipy.test() Need nose >= 0.10

Robert Kern robert.kern@gmail....
Thu May 22 02:51:30 CDT 2008


On Thu, May 22, 2008 at 2:42 AM, Sebastian Haase <haase@msg.ucsf.edu> wrote:
>> Install nose.
>>
>> http://www.somethingaboutorange.com/mrl/projects/nose/
>>
> Is this now a (hard) dependency of SciPy !?

For running the unit tests, yes.

> My understanding that SciPy would not have any dependencies (besides
> numpy of course) .... not even BLAS ...

We're relaxing that for the unit tests (and just the unit tests).

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
 -- Umberto Eco


More information about the SciPy-user mailing list