[SciPy-user] Problem with mkl 10.0.2: undefined symbol: mkl_blas_xdgemm_1_thr_htn

Anand Patil anand.prabhakar.patil@gmail....
Mon Nov 3 07:13:05 CST 2008


On Mon, Nov 3, 2008 at 1:03 PM, Matthieu Brucher <matthieu.brucher@gmail.com
> wrote:

> 2008/11/3 Anand Patil <anand.prabhakar.patil@gmail.com>:
> > Hi Matthieu,
> >
> > It works with:
> >
> > [mkl]
> > library_dirs = /opt/intel/mkl/10.0.5.025/lib/em64t
> > lapack_libs = mkl, mkl_lapack
> > mkl_libs = mkl_core, mkl_def, mkl_vml_def, mkl_intel_thread,
> mkl_sequential,
> > guide, mkl_em64t, mkl
>
> I think you try to link with too many libraries. If you can, use only
> mkl, guide, iomp5, pthread. If the issue (the missing symbol) arises
> again, use libmkl_intel_lp64, libmkl_sequential, libmkl_core only (see
> the MKL user guide a well for more information about the different
> threading models).
>
> Matthieu
> --
> Information System Engineer, Ph.D.
> Website: http://matthieu-brucher.developpez.com/
> Blogs: http://matt.eifelle.com and http://blog.developpez.com/?blog=92
> LinkedIn: http://www.linkedin.com/in/matthieubrucher
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
>

Thanks Matthieu,

The diagonal of B is still zero with both collections of libraries. I'll
have a look through the MKL user guide and see if I can't resolve this,
please let me know if you think of anything also.

Anand
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20081103/7f549ce4/attachment-0001.html 


More information about the SciPy-user mailing list