[SciPy-user] Ubuntu Libraries

Ondrej Certik ondrej@certik...
Mon Oct 6 20:47:54 CDT 2008


On Mon, Oct 6, 2008 at 7:47 PM, jah <jah.mailinglist@gmail.com> wrote:
> Hi,
>
> I was hoping someone could clarify the ubuntu packages and what is actually
> needed by scipy.
>
> 1) I keep seeing posts about g77 not being required anymore and gfortran
> preferred.  What is the "official" statement?  In INSTALL.txt, only g77 is
> mentioned for Ubuntu packages via:  """Debian/Ubuntu packages (g77):
> atlas3-base atlas3-base-dev""".  The only reference to gfortran is with Mac
> OS X.  Also, in "Optional Packages" debian packages 'gcc g++ g77' are
> recommened.

Debian (and thus Ubuntu as well) has transitioned from g77 to
gfortran, so only gfortran is needed.

>
> 2) The install notes also say that a complete version of LAPACK is required
> for scipy.  All the ubuntu descriptions say that only a subset of routines
> from LAPACK are included with ATLAS.  For example,
> http://packages.ubuntu.com/hardy/libatlas-sse2-dev.  Is this a problem?

As far as I know, you can use atlas instead interchangebly. You can
find some (fixed) Debian bug reports about that in the python-numpy
package.

>
> 3) It looks like there are two packages:  atlas3-sse2 and
> libatlas-sse2-dev.  Are both required?  It seems that they refer to
> different versions of ATLAS.
>
>  http://packages.ubuntu.com/hardy/atlas3-sse2
>  http://packages.ubuntu.com/hardy/libatlas-sse2-dev
>
> On reading http://www.scipy.org/Installing_SciPy/Linux, it seems like I only
> should need libatlas-sse2-dev.  Correct?

The easiest way to determine the build dependencies is to do:

$ apt-get source python-scipy
$ cd python-scipy-0.6.0/
$ cat debian/control
Source: python-scipy
Section: python
Priority: extra
Maintainer: Debian Python Modules Team
<python-modules-team@lists.alioth.debian.org>
Uploaders: Alexandre Fayolle <afayolle@debian.org>, Marco Presi
(Zufus) <zufus@debian.org>, Ondrej Certik <ondrej@certik.cz>
Build-Depends: debhelper (>= 5.0.37.2), dpkg-dev (>= 1.13.19), quilt,
 python-all-dev, python-central (>= 0.5), python-numpy (>= 1:1.0.2), gfortran,
 sharutils, swig, libsuitesparse-dev (>= 3.1.0-3), libnetcdf-dev,
 libx11-dev, libblas-dev | libatlas-base-dev, liblapack-dev | libatlas-base-dev,
 libfftw3-dev
XS-Python-Version: all
Standards-Version: 3.8.0
Homepage: http://www.scipy.org/
Vcs-Svn: svn://svn.debian.org/python-modules/packages/scipy/trunk
Vcs-Browser: http://svn.debian.org/wsvn/python-modules/packages/scipy/trunk/?op=log
XS-DM-Upload-Allowed: yes


And you can read the Build-Depends right away.

Btw, is there any reason why the official Debian/Ubuntu packages are
not sufficient for you? I.e. is it because you need the svn version of
scipy? I haven't checked out if the svn scipy builds using the same
build dependencies as 0.6.0, that's true.

Ondrej


More information about the SciPy-user mailing list