[SciPy-user] scipy 0.6 installation problem on os x 10.5.5

Ritchie voodoochild2006@gmail....
Sun Oct 26 11:50:16 CDT 2008


I'm trying to install scipy 0.6 on my leopard MBP, after a
python setup.py build

as root, I got the following error message :

 compiler: gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp
-mno-fused-madd -fno-common -dynamic -DNDEBUG -g -Os -Wall
-Wstrict-prototypes -DMACOSX -I/usr/include/ffi -DENABLE_DTRACE -arch i386
-arch ppc -pipe

creating build/temp.macosx-10.5-i386-2.5/scipy/optimize/Zeros
compile options: '-c'
gcc: scipy/optimize/Zeros/brenth.c
cc1: error: unrecognized command line option "-Wno-long-double"
cc1: error: unrecognized command line option "-Wno-long-double"
lipo: can't open input file: /var/tmp//ccaG7ngI.out (No such file or
directory)
cc1: error: unrecognized command line option "-Wno-long-double"
cc1: error: unrecognized command line option "-Wno-long-double"
lipo: can't open input file: /var/tmp//ccaG7ngI.out (No such file or
directory)
error: Command "gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp
-mno-fused-madd -fno-common -dynamic -DNDEBUG -g -Os -Wall
-Wstrict-prototypes -DMACOSX -I/usr/include/ffi -DENABLE_DTRACE -arch i386
-arch ppc -pipe -c scipy/optimize/Zeros/brenth.c -o
build/temp.macosx-10.5-i386-2.5/scipy/optimize/Zeros/brenth.o" failed with
exit status 1


I googled for a while, could not find any solution. Anybody has any idea?
I'm using xcode 3.1.1, gcc-4.2.1, gfortran-4.2.3.

Another problem is that if I do a

sudo python setup.py build

as a normal user, I will have the following error message :

  adding 'scipy/sparse/linalg/dsolve/umfpack/umfpack.i' to sources.
swig: scipy/sparse/linalg/dsolve/umfpack/umfpack.i
swig -python -o
build/src.macosx-10.5-i386-2.5/scipy/sparse/linalg/dsolve/umfpack/_umfpack_wrap.c
-outdir build/src.macosx-10.5-i386-2.5/scipy/sparse/linalg/dsolve/umfpack
scipy/sparse/linalg/dsolve/umfpack/umfpack.i
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:192: Error: Unable to find
'umfpack.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:193: Error: Unable to find
'umfpack_solve.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:194: Error: Unable to find
'umfpack_defaults.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:195: Error: Unable to find
'umfpack_triplet_to_col.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:196: Error: Unable to find
'umfpack_col_to_triplet.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:197: Error: Unable to find
'umfpack_transpose.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:198: Error: Unable to find
'umfpack_scale.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:200: Error: Unable to find
'umfpack_report_symbolic.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:201: Error: Unable to find
'umfpack_report_numeric.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:202: Error: Unable to find
'umfpack_report_info.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:203: Error: Unable to find
'umfpack_report_control.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:215: Error: Unable to find
'umfpack_symbolic.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:216: Error: Unable to find
'umfpack_numeric.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:225: Error: Unable to find
'umfpack_free_symbolic.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:226: Error: Unable to find
'umfpack_free_numeric.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:248: Error: Unable to find
'umfpack_get_lunz.h'
scipy/sparse/linalg/dsolve/umfpack/umfpack.i:272: Error: Unable to find
'umfpack_get_numeric.h'
error: command 'swig' failed with exit status 1


even though I updated and export my $UMFPACK variable. However root does not
have this problem.


Thank you
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20081026/5be4a40f/attachment.html 


More information about the SciPy-user mailing list