[SciPy-user] having problems with fortran compiler on Mac OS X 10.5.2

Robert Kern robert.kern@gmail....
Thu Sep 18 15:11:22 CDT 2008


On Thu, Sep 18, 2008 at 14:23, Kiana Toufighi <kianatoufighi@hotmail.com> wrote:
> Hi Robert,
>
> Thanks for the reply. When I try building with python setup.py config_fc
> --fcompiler=gnu95 build
> the last few lines of output are:
>
> running build_clib
> customize UnixCCompiler
> customize UnixCCompiler using build_clib
> Could not locate executable g77
> Could not locate executable f77
> Could not locate executable f95
> customize Gnu95FCompiler
> Couldn't match compiler version for 'GNU Fortran (GCC) 4.2.3\nCopyright (C)
> 2007 Free Software Foundation, Inc.\n\nGNU Fortran comes with NO WARRANTY,
> to the extent permitted by law.\nYou may redistribute copies of GNU
> Fortran\nunder the terms of the GNU General Public License.\nFor more
> information about these matters, see the file named COPYING\n'

What version of numpy do you have? I use this version of gfortran on
10.5.2, too, with SVN numpy, but it looks like numpy 1.1.1 has the
same version-processing code. numpy 1.2.0 will be out very shortly,
too.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
 -- Umberto Eco


More information about the SciPy-user mailing list