[SciPy-user] [Timeseries] Linux installation error

Pierre GM pgmdevlist@gmail....
Thu Apr 2 17:10:36 CDT 2009


On Apr 2, 2009, at 5:52 PM, Christiaan Putter wrote:

> Hi guys and girls,
>
> I just installed the timeseries module on linux after updating to the
> latest numpy 1.3 on python2.5.

Ah, an early adopter who failed into our trap...
We detected a pb in the latest sources of scikits.timeseries. I'll  
send you a proper dist off-list, the files should be uploaded on  
sourceforge in the next 24h.


> Another question:  Is numpy1.3 really necessary seeing as it's still
> only in testing?  Most of my users use the enthought python
> distribution which still has an older numpy version bundled with it.

Oh yes. numpy 1.3 improves supports for structured arrays in numpy.ma  
and introduces numpy.lib.io.genfromtxt, two new features  
scikits.timeseries make extensive use of.

That's basically why we didn't make any official release announcement  
yet: we're waiting for numpy 1.3 to be released first. We're just  
getting ready, with relative success as you have unfortunately  
experienced.
In any case, please accept all our sincere apologies for any  
inconvenience.
P.



More information about the SciPy-user mailing list