[SciPy-user] Compile scipy from SVN on OS X: no clapack ?

Pierre GM pgmdevlist@gmail....
Tue Apr 7 16:52:00 CDT 2009


All,
I'm working on a piece of code that requires numerous calls to  
scipy.linalg.eigvals. I was surprised by the slowness of the code, so  
I figured I'd check whether my installation of scipy was correct.  
Turns out it's probably not: running the tests, I end up w/ some  
messages indicating that clapack is empty. That never really mattered  
until now...
Could anybody try and hold my hand on this one (I'm still a newbie on  
Mac) ?

* I do have an Accelerate framework in my /System/Library
* The python I use is the 2.5.4 from macports
* I have a macports atlas (v3.8.2)
* I do want to compile from source: I usually install scipy/numpy w/  
python -c "import setuptools; execfile('setup.py')" develop in virtual  
environments (that way, I can get the latest changes I make straight  
away).
* extra config info below

Obviously I'm missing some configuration step somewhere, or I'm mixing  
things that shouldn't be.

Note that following the info in INSTALL.txt, I tried to run
python setup_atlas_version.py build_ext --inplace --force
but failed w/ a
Traceback (most recent call last):
  File "setup_atlas_version.py", line 7, in <module>
    from numpy.distutils.misc_util import get_path, default_config_dict
ImportError: cannot import name get_path

Any help welcome.
Thanks an awful lot in advance
P.

__________

 >>> python setup.py build 2>&1 | tee build.log
File downloadable at
http://rapidshare.com/files/218658464/build.log.html

__________
 >>> python -c "from numpy.f2py.diagnose import run; run()"
------
os.name='posix'
------
sys.platform='darwin'
------
sys.version:
2.5.4 (r254:67916, Apr  1 2009, 17:15:22)
[GCC 4.0.1 (Apple Inc. build 5490)]
------
sys.prefix:
/Users/pierregm/Computing/.pythonenvs/default/bin/..
------
sys.path=':/Users/pierregm/Computing/.pythonenvs/default/lib/python2.5/ 
site-packages/setuptools-0.6c9-py2.5.egg:/Users/pierregm/ 
Computing/.pythonenvs/default/lib/python2.5/site-packages/ 
ipython-0.9.1-py2.5.egg:/Users/pierregm/Computing/workspace/svn_numpy:/ 
Users/pierregm/Computing/.pythonenvs/default/lib/python2.5/site- 
packages/nose-0.10.4-py2.5.egg:/Users/pierregm/Computing/workspace/ 
svn_scipy:/Users/pierregm/Computing/.pythonenvs/default/lib/python2.5/ 
site-packages/BeautifulSoup-3.1.0.1-py2.5.egg:/Users/pierregm/ 
Computing/.pythonenvs/default/lib/python2.5/site-packages/xlrd-0.6.1- 
py2.5.egg:/Users/pierregm/Computing/.pythonenvs/default/lib/python2.5/ 
site-packages/Sphinx-0.6.1-py2.5.egg:/Users/pierregm/ 
Computing/.pythonenvs/default/lib/python2.5/site-packages/Jinja2-2.1.1- 
py2.5-macosx-10.5-i386.egg:/Users/pierregm/Computing/.pythonenvs/ 
default/lib/python2.5/site-packages/SquareMap-1.0.0b23-py2.5.egg:/ 
Users/pierregm/Computing/.pythonenvs/default/lib/python2.5/site- 
packages/RunSnakeRun-2.0.0b4-py2.5.egg:/opt/local/Library/Frameworks/ 
Python.framework/Versions/2.5/lib/python2.5/site-packages/Jinja-1.2- 
py2.5-macosx-10.3-i386.egg:/opt/local/Library/Frameworks/ 
Python.framework/Versions/2.5/lib/python2.5/site-packages/ 
Pygments-0.11.1-py2.5.egg:/opt/local/Library/Frameworks/ 
Python.framework/Versions/2.5/lib/python2.5/site-packages/yolk-0.4.1- 
py2.5.egg:/opt/local/Library/Frameworks/Python.framework/Versions/2.5/ 
lib/python2.5/site-packages/Sphinx-0.5-py2.5.egg:/opt/local/Library/ 
Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/ 
cocos2d-0.3.0-py2.5.egg:/opt/local/Library/Frameworks/Python.framework/ 
Versions/2.5/lib/python2.5/site-packages/virtualenv-1.3.2-py2.5.egg:/ 
Users/pierregm/Computing/workspace/hydroclimpy:/Users/pierregm/ 
Computing/workspace/svn_scikits_timeseries:/Library/Frameworks/ 
GDAL.framework/Versions/1.6/lib:/Users/pierregm/Computing/.pythonenvs/ 
default/lib/python25.zip:/Users/pierregm/Computing/.pythonenvs/default/ 
lib/python2.5:/Users/pierregm/Computing/.pythonenvs/default/lib/ 
python2.5/plat-darwin:/Users/pierregm/Computing/.pythonenvs/default/ 
lib/python2.5/plat-mac:/Users/pierregm/Computing/.pythonenvs/default/ 
lib/python2.5/plat-mac/lib-scriptpackages:/Users/pierregm/ 
Computing/.pythonenvs/default/lib/python2.5/lib-tk:/Users/pierregm/ 
Computing/.pythonenvs/default/lib/python2.5/lib-dynload:/opt/local/ 
Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5:/opt/ 
local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/ 
lib-tk:/opt/local/Library/Frameworks/Python.framework/Versions/2.5/lib/ 
python2.5/plat-darwin:/opt/local/Library/Frameworks/Python.framework/ 
Versions/2.5/lib/python2.5/plat-mac:/opt/local/Library/Frameworks/ 
Python.framework/Versions/2.5/lib/python2.5/plat-mac/lib- 
scriptpackages:/Users/pierregm/Computing/.pythonenvs/default/lib/ 
python2.5/site-packages:/opt/local/Library/Frameworks/Python.framework/ 
Versions/2.5/lib/python2.5/site-packages:/opt/local/Library/Frameworks/ 
Python.framework/Versions/2.5/lib/python2.5/site-packages/Numeric:/opt/ 
local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/ 
site-packages/PyObjC:/opt/local/Library/Frameworks/Python.framework/ 
Versions/2.5/lib/python2.5/site-packages/gtk-2.0:/opt/local/lib/ 
python2.5/site-packages:/opt/local/lib/svn-python2.5:/opt/local/ 
Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site- 
packages/wx-2.8-mac-unicode'
------
Failed to import numarray: No module named numarray
Found Numeric version '24.2' in /opt/local/Library/Frameworks/ 
Python.framework/Versions/2.5/lib/python2.5/site-packages/Numeric/ 
Numeric.pyc
Found new numpy version '1.4.0.dev' in /Users/pierregm/Computing/ 
workspace/svn_numpy/numpy/__init__.pyc
Found f2py2e version '2' in /Users/pierregm/Computing/workspace/ 
svn_numpy/numpy/f2py/f2py2e.pyc
Found numpy.distutils version '0.4.0' in '/Users/pierregm/Computing/ 
workspace/svn_numpy/numpy/distutils/__init__.pyc'
------
Importing numpy.distutils.fcompiler ... ok
------
Checking availability of supported Fortran compilers:
Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /Builds/unix/gcc/gcc-4.2/configure --prefix=/usr/ 
local --mandir=/share/man --program-transform-name=/^[cg][^.-]*$/s/ 
$/-4.2/ --build=i686-apple-darwin8 --host=i686-apple-darwin8 -- 
target=powerpc-apple-darwin8 --enable-languages=fortran
Thread model: posix
gcc version 4.2.3
Using built-in specs.
Target: i686-apple-darwin8
Configured with: /Builds/unix/gcc/gcc-4.2/configure --prefix=/usr/ 
local --mandir=/share/man --program-transform-name=/^[cg][^.-]*$/s/ 
$/-4.2/ --build=i686-apple-darwin8 --host=i686-apple-darwin8 -- 
target=i686-apple-darwin8 --enable-languages=fortran
Thread model: posix
gcc version 4.2.3
Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /Builds/unix/gcc/gcc-4.2/configure --prefix=/usr/ 
local --mandir=/share/man --program-transform-name=/^[cg][^.-]*$/s/ 
$/-4.2/ --build=i686-apple-darwin8 --host=i686-apple-darwin8 -- 
target=powerpc-apple-darwin8 --enable-languages=fortran
Thread model: posix
gcc version 4.2.3
Using built-in specs.
Target: i686-apple-darwin8
Configured with: /Builds/unix/gcc/gcc-4.2/configure --prefix=/usr/ 
local --mandir=/share/man --program-transform-name=/^[cg][^.-]*$/s/ 
$/-4.2/ --build=i686-apple-darwin8 --host=i686-apple-darwin8 -- 
target=i686-apple-darwin8 --enable-languages=fortran
Thread model: posix
gcc version 4.2.3
Gnu95FCompiler instance properties:
  archiver        = ['/usr/local/bin/gfortran', '-cr']
  compile_switch  = '-c'
  compiler_f77    = ['/usr/local/bin/gfortran', '-Wall', '-ffixed- 
form', '-
                    fno-second-underscore', '-arch', 'ppc', '-arch',  
'i686', '
                    -fPIC', '-O3', '-funroll-loops']
  compiler_f90    = ['/usr/local/bin/gfortran', '-Wall', '-fno-second-
                    underscore', '-arch', 'ppc', '-arch', 'i686', '- 
fPIC', '-
                    O3', '-funroll-loops']
  compiler_fix    = ['/usr/local/bin/gfortran', '-Wall', '-ffixed- 
form', '-
                    fno-second-underscore', '-Wall', '-fno-second- 
underscore',
                    '-arch', 'ppc', '-arch', 'i686', '-fPIC', '-O3', '- 
funroll
                    -loops']
  libraries       = ['gfortran']
  library_dirs    = []
  linker_exe      = ['/usr/local/bin/gfortran', '-Wall', '-Wall']
  linker_so       = ['/usr/local/bin/gfortran', '-Wall', '-arch',  
'ppc', '-
                    arch', 'i686', '-Wall', '-undefined',  
'dynamic_lookup', '-
                    bundle']
  object_switch   = '-o '
  ranlib          = ['/usr/local/bin/gfortran']
  version         = LooseVersion ('4.2.3')
  version_cmd     = ['/usr/local/bin/gfortran', '--version']
Fortran compilers found:
  --fcompiler=gnu95  GNU Fortran 95 compiler (4.2.3)
Compilers available for this platform, but not found:
  --fcompiler=absoft  Absoft Corp Fortran Compiler
  --fcompiler=g95     G95 Fortran Compiler
  --fcompiler=gnu     GNU Fortran 77 compiler
  --fcompiler=ibm     IBM XL Fortran Compiler
  --fcompiler=intel   Intel Fortran Compiler for 32-bit apps
  --fcompiler=nag     NAGWare Fortran 95 Compiler
Compilers not available on this platform:
  --fcompiler=compaq   Compaq Fortran Compiler
  --fcompiler=hpux     HP Fortran 90 Compiler
  --fcompiler=intele   Intel Fortran Compiler for Itanium apps
  --fcompiler=intelem  Intel Fortran Compiler for EM64T-based apps
  --fcompiler=intelev  Intel Visual Fortran Compiler for Itanium apps
  --fcompiler=intelv   Intel Visual Fortran Compiler for 32-bit apps
  --fcompiler=lahey    Lahey/Fujitsu Fortran 95 Compiler
  --fcompiler=mips     MIPSpro Fortran Compiler
  --fcompiler=none     Fake Fortran compiler
  --fcompiler=pg       Portland Group Fortran Compiler
  --fcompiler=sun      Sun or Forte Fortran 95 Compiler
  --fcompiler=vast     Pacific-Sierra Research Fortran 90 Compiler
For compiler details, run 'config_fc --verbose' setup command.
------
Importing numpy.distutils.cpuinfo ... ok
------
CPU information: CPUInfoBase__get_nbits getNCPUs is_32bit is_i386 ------



More information about the SciPy-user mailing list