[SciPy-user] enthought distribution problem

Ranjit Chacko rjchacko@gmail....
Wed Apr 15 13:19:43 CDT 2009


I just installed the Enthought distribution of scipy on my Mac running  
Leopard and I got the following error message when I tried to run  
Ipython.  Any ideas on how to fix this?:

------------------------------------------------------------
Traceback (most recent call last):
   File "<string>", line 1, in <module>
ImportError: No module named sage.misc.preparser_ipython

WARNING: Failure executing code: 'import sage.misc.preparser_ipython;   
sage.misc.preparser_ipython.magma_colon_equals=True'
ERROR: history is not a magic function
------------------------------------------------------------
Traceback (most recent call last):
   File "/Library/Frameworks/Python.framework/Versions/4.1.30101/lib/ 
python2.5/site-packages/ipython-0.9.1.0001_s-py2.5.egg/IPython/ 
ipmaker.py", line 66, in force_import
     __import__(modname)
ImportError: No module named ipy_user_conf

WARNING: /Users/rjchacko/.ipython/ipy_user_conf.py does not exist,  
please run %upgrade!
WARNING: Loading of ipy_user_conf failed.

<ERROR: name 'sage_prompt' is not defined>



More information about the SciPy-user mailing list