[SciPy-user] Building Python, Numpy and Scipy with Intel compilers and MKL

David Cournapeau david@ar.media.kyoto-u.ac...
Tue Apr 28 23:43:06 CDT 2009


Craig Finch wrote:
> I spoke too soon!  Upon further testing of Numpy, I find that I cannot import the "sparsetools" package, which is built using Swig (details of the error below).  The system version of Swig is 1.3.29, built with g++.  Is it possible that Swig is causing a problem here?  Any other suggestions?
>   

I think C++ ABI incompatibility is the problem, not swig.  Icc has some
options to set up the g++ ABI, and some  icc are incompatible with some
g++ versions as well (the error seems to be related to the io C++
library). Maybe you could try compiling the c++ part with g++,

cheers,

David


More information about the SciPy-user mailing list