[SciPy-user] audiolab Problem

David Cournapeau david@ar.media.kyoto-u.ac...
Thu Feb 5 04:30:02 CST 2009


Georg Holzmann wrote:
> Hallo David!
>
> I have a problem with using the scikits.audiolab package (from svn) on 
> latest ubuntu (python 2.5.2, numpy 1.1.1).
>   

Hi Georg,

    Audiolab requires numpy 1.2 or above. I think we should push numpy
1.2 to Ubuntu 9.04 while there is still time - 1.2 was a significant
release.

> When I want to import the module I get the following error:
>      import scikits.audiolab
>    File "/usr/lib/python2.5/site-packages/scikits/audiolab/__init__.py", 
> line 37, in <module>
>      from numpy.testing import Tester
> ImportError: cannot import name Tester
>   

This has nothing to do with the problem, but may I suggest not to
install anything from sources into /usr/ ? You should install either in
/usr/local or somewhere else, because if audiolab becomes packaged by
Ubuntu, you will mess up things. It is a good idea to never install
anything from sources in /usr,

> At least in my numpy version there is no Tester class in numpy.testing.
> Ok, so I just removed this line in the __init__ file ...
>
> However, I wanted to run the tests, because you wrote on the audiolab 
> website, that there can be a nasty bug with integers which corrupts the 
> audio ...
>   

Yes, there was a ctypes bug in old Ubuntu. The new audiolab version
should avoid this problem altogether.

> Do you have a clue whats the problem ?
> In my numpy version the test cases have a different name ...
> Or do I need to run these tests on latest Ubuntu - is the integer bug 
> still a problem ?
>   

Not on recent Ubuntu releases, no.

David


More information about the SciPy-user mailing list