[SciPy-user] Help on installation of scipy

yelver huang yelvergm@gmail....
Thu Feb 12 19:39:07 CST 2009


Hi all,
I have encountered some problems on installing scipy on Windows, though it's
quite simple. There is no fault for me to import numpy from Python25, but
after I install the binary file of scipy, I could not import it. The error
it shows is:

Warning (from warnings module):
  File "G:\Python25\lib\site-packages\scipy\__init__.py", line 30
    UserWarning)
UserWarning: Numpy 1.2.0 or above is recommended for this version of scipy
(detected version 1.0.4)

Traceback (most recent call last):
  File "<pyshell#1>", line 1, in <module>
    import scipy
  File "G:\Python25\Lib\site-packages\scipy\__init__.py", line 75, in
<module>
    from numpy.testing import Tester
ImportError: cannot import name Tester

The version of numpy in my computer is 1.2.1, I could not understand this
message. Hope someone could help me.

Thanks,

Tao
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20090212/4a34152b/attachment-0001.html 


More information about the SciPy-user mailing list