[SciPy-user] Scipy 0.7, weave, windows

David Cournapeau cournape@gmail....
Fri Jan 9 06:31:20 CST 2009


On Fri, Jan 9, 2009 at 5:00 AM, Daniel Wheeler
<daniel.wheeler2@gmail.com> wrote:
> On Thu, Jan 8, 2009 at 11:15 AM, David Cournapeau <cournape@gmail.com> wrote:
>> On Fri, Jan 9, 2009 at 12:49 AM, Daniel Wheeler
>> <daniel.wheeler2@gmail.com> wrote:
>>> On Thu, Jan 8, 2009 at 10:19 AM, David Cournapeau
>>> <david@ar.media.kyoto-u.ac.jp> wrote:
>>>> Hi,
>>>>
>>>>    I just did a full build/install/test dance of scipy 0.7 on windows,
>>>> and things look good - except weave, which brings 205 errors when the
>>>> full test suite is run. Do people use weave on windows ?
>>>
>>> Yes. Our test suite for fipy currently passes all it's weave tests on
>>> windows with python 2.5 and scipy version 0.6.0 and that includes a
>>> lot of auto generated weave code.
>>
>> Thanks for the info. Would you mind testing it with scipy 0.7.x branch
>> ? There are some test failures which showed some old code which could
>> not have worked (like using python code which was removed from python
>> svn 5 years ago), but as I am not a weave user myself, I can't really
>> assess what's significant and what's not.
>>
>> I could make a binary installer if that makes it easier for you to test,
>
> That would be great if you have it set to build quickly and easily.
> Don't fancy figuring out how to build scipy on windows. Cheers.

No need to worry, I am the one who coded the tools for the windows
binary installer, so hopefully I am still familiar with it :)

Here we are:

http://www.ar.media.kyoto-u.ac.jp/members/david/archives/scipy/scipy-0.7.0.dev5410-win32-superpack-python2.5.exe

David


More information about the SciPy-user mailing list