[SciPy-user] python 2.6.2 mac os x (import signal causes a Bus Error)

Russell E. Owen rowen@uw....
Tue Jul 14 13:33:10 CDT 2009


In article <4A5BEFBE.7040006@ar.media.kyoto-u.ac.jp>,
 David Cournapeau <david@ar.media.kyoto-u.ac.jp> wrote:

> Rajanikanth Jammalamadaka wrote:
> > I tried it on another system (also Mac OS X) which had numpy version
> > 1.3 and it seems to work fine on that one.
> >
> > So, is it a version problem?
> >   
> 
> Yes - if you use the official scipy binary, you need to use the
> corresponding official numpy binary (which is 1.3.0 for python 2.6). As
> an alternative, you can build scipy by yourself against numpy - in this
> case, you can use numpy 1.2.1.

Except that numpy 1.3.0 is the minimum version that is compatible with 
Python 2.6.

-- Russell



More information about the SciPy-user mailing list