[SciPy-user] [Numpy-discussion] scipy 0.7.1 rc3

David Cournapeau cournape@gmail....
Sat Jun 13 21:51:53 CDT 2009


On Sun, Jun 14, 2009 at 11:20 AM, <josef.pktd@gmail.com> wrote:

>
> But it's a trivial fix, to get the status back of before 0.7.0 for
> pure mingw users like me.

I meant that it won't help for the known failures.

>
> What I don't understand is why in platform_info.py the function
> `choose_compiler` doesn't ask distutils what the default compiler is,
> the one specified in distutils.cfg, instead of doing its own
> determination.

weave code is fairly old, so maybe it was coded before
numpy.distutils/distutils had proper mingw support. To know for sure,
you would need to get into svn log/blame between numpy and scipy to
see the history.

David


More information about the SciPy-user mailing list