[SciPy-user] Eigenvalues of the Floquet matrix

Rob Clewley rob.clewley@gmail....
Mon Mar 16 10:00:26 CDT 2009


>>
>> It would be really nice to have a setup.py ;-)

I know, I'm trying to pay somebody this spring to write me one!

> /home/nwagner/local/lib64/python2.6/site-packages/Pyrex/Compiler/Errors.py:17:
> DeprecationWarning: BaseException.message has been
> deprecated as of Python 2.6

OK, for a start PyDSTool has not been tested at all on Python 2.6. I
just haven't been able to keep up! If there's any chance you can also
have 2.4.3 or 2.5 on your system then that would be the easiest thing
to do. I know that people have installed successfully recently from
SVN on Python 2.5. Maybe I need to post a clear disclaimer on my
webpage since Python 2.6 has become so common.

> Error occurred in generating Radau system
> (while moving library extension modules to CWD)
> <type 'exceptions.TypeError'> cannot concatenate 'str' and
> 'int' objects
> Traceback (most recent call last):
>   File "seyranian-PyDSTool.py", line 43, in <module>
>     osc = Generator.Radau_ODEsystem(DSargs)
>   File
> "/home/nwagner/svn/PyDSTool/PyDSTool/Generator/Radau_ODEsystem.py",
> line 545, in __init__
>     self.compileLib()
>   File
> "/home/nwagner/svn/PyDSTool/PyDSTool/Generator/Radau_ODEsystem.py",
> line 991, in compileLib
>     raise RuntimeError
> RuntimeError
>
>
> Any idea ?

I don't have a clue right now.

The list of test failures you sent me is pretty catastrophic, which
makes me suspect the problem is something basic in python that has
changed between 2.5 and 2.6 that is at the heart of every one of the
tests.

And/or it's something to do with Pyrex getting involved for the legacy
ODE solvers. I don't know why the pyrex compiler is being invoked,
because it should be gcc. Can you look at the wiki GettingStarted page
(Section 1.4.5.) on getting C integrators set up on Linux and tell me
if you've set up SWIG and set the CC environment variable?

-Rob


More information about the SciPy-user mailing list