[SciPy-user] Sparse factorisation

Robert Cimrman cimrman3@ntc.zcu...
Fri May 1 04:07:26 CDT 2009


Gael Varoquaux wrote:
> On Fri, May 01, 2009 at 05:08:37PM +0900, David Cournapeau wrote:
>> Gael Varoquaux wrote:
>>> On Thu, Apr 30, 2009 at 08:52:28PM -0700, Ondrej Certik wrote:
> 
>>>> Is umfpack in scipy really broken? That is very disappointing. 
> 
>>> There are some signs of it being depreciated in the source code.
> 
>> umfpack is under the GPL. My understanding is that new contributions to
>> umfpack should go to the corresponding scikit.
> 
> Right, new versions of UMFPACK are indeed under GPL. I just noticed that.
> Have you tried contacting Tim Davis about that. The web page does suggest
> to contacting him for distributing UMFPACK under a different license. My
> guess is that distirbuting UMFPACK under BSD with scipy would be contrary
> to distributing it under GPL in the main download page, so our chances
> are small.
> 
> Now I understand better the switch to SuperLU.

Yes, we have tried to contact Tim Davis (me and Nathan Bell, if I 
remeber correctly?), but he refused to provide an exception for scipy. 
That is why the umfpack wrappers (written quite a time ago by me) were 
changed into the umfpack scikit. Now there is a situation when some 
version of the wrappers still survives in scipy proper, while another 
version is in the scikit. This is not good, I know, but I have been very 
busy recently. But I use the wrappers on a daily basis without problem 
myself - if you have problems, open a ticket, please, and notify me.

r.


More information about the SciPy-user mailing list