[SciPy-user] Sparse factorisation

Gael Varoquaux gael.varoquaux@normalesup....
Fri May 1 06:19:08 CDT 2009


On Fri, May 01, 2009 at 12:40:32PM +0200, Gael Varoquaux wrote:
> As you have mentioned on the track ticket, the build is failing, and
> we'll fix this.

OK, that was purely on my side. I was being stupid: I did not have the
proper headers installed.

> I'll cook up a patch to get things working on my system, with a proper
> error message.

So, I'll make only an error message, something like:


Something like:

"""
Scipy was built without umfpack support. For umfpack, you need to install
umfpack and the developement headers before building scipy.
"""

We can add this on the import failure, scipy/sparse/linalg/dsolve/umfpack
$ vim umfpack.py, line 13, in with case we need to delay this import. The
other option is to add the error message in the init of UmfpackContext.
It wouid thus give a meangingful error message if _um is None.

What do you think?

Gaël


More information about the SciPy-user mailing list