[SciPy-user] scipy import problem when running from terminal

Stéfan van der Walt stefan@sun.ac...
Sun May 3 18:46:55 CDT 2009


Hi David

2009/5/4 David Vine <djvine@gmail.com>:
> when I execute my python scripts from the terminal (ubuntu 9.04) the scipy
> module cannot be found when i try to import it and i get an ImportError
> exception. However I am confident that the scipy module is installed
> correctly because calling the same script from within IPython  using
> execfile has no problem finding the scipy module.

I noticed that python 2.6 is now the default on Ubuntu, but you may
have the 2.5 packages for SciPy and IPython installed.

Maybe try "python2.5 myscript.py".

Cheers
Stéfan


More information about the SciPy-user mailing list