[SciPy-user] when will scipy win32 for Python2.6 be ready

David Cournapeau david@ar.media.kyoto-u.ac...
Wed May 6 00:08:32 CDT 2009


Shawn GONG wrote:
>
> hi,
>
> I am running Python2.6 and MS VS 2005 on Windows XP.
> I'd like to use scipy. When will scipy binary install for Python2.6 be
> ready?
>

Hopefully, scipy 0.7.1 will have a python 2.6 binary.

> I tried to run "python setup.py install", but got error message saying:
>   numpy.distutils.system_info.BlasNotFoundError:
>     Blas (http://www.netlib.org/blas/) libraries not found.
>     Directories to search for the libraries can be specified in the
>     numpy/distutils/site.cfg file (section [blas]) or by setting
>     the BLAS environment variable.
>

Yes, you need both BLAS and LAPACK to build scipy by yourself. Building
them is a bit difficult on windows,

cheers,

David


More information about the SciPy-user mailing list