[SciPy-User] SciPy installation problems

Robert Kern robert.kern@gmail....
Thu Nov 5 14:20:25 CST 2009


On Thu, Nov 5, 2009 at 12:37, Gaston Fiore <gaston.fiore@gmail.com> wrote:
> Hello,
>
> I'm trying to install scipy from the SVN repository but I'm getting an
> error. I've also discovered that numpy doesn't pass the built-in unit
> tests, although it did seem to install without problems. Below is all
> the information that I think it's needed to determine the problem and
> its solution. Is it the fact that UMFPACK is missing?

No.

>>>> import numpy
>>>> numpy.test('1','10')

It's "numpy.test(1, 10)".

> dhcp-0011377089-64-8f:scipy gafiore$ python setup.py build

>  File "scipy/special/setup.py", line 7, in <module>
>    from numpy.distutils.misc_util import get_numpy_include_dirs, get_info
> ImportError: cannot import name get_info

The version of numpy supplied with the OS is very old. You will need a
newer version in order to build this version of scipy. I recommend
avoiding the system's installation of Python entirely and using the
binaries from python.org instead.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco


More information about the SciPy-User mailing list