[SciPy-User] scipy.linalg.det TypeError

Norm Wood nbwood@lamar.colostate....
Fri Oct 30 12:24:09 CDT 2009



On 29 Oct., David Goldsmith wrote:
> Uncertain why you're having a problem - your sample code works for me:
> 
> >>> import scipy.linalg
> >>> import numpy.linalg
> >>> A=np.matrix([[1.1, 1.9],[1.9,3.5]])
> >>> y = numpy.linalg.det(A); y
> 0.23999999999999988
> >>> y = scipy.linalg.det(A); y
> 0.23999999999999988
> >>> scipy.__version__
> '0.7.1'
> >>> np.__version__
> '1.3.0rc2'
> Python 2.5 on Windoze Vista HPE


Thanks for checking, David.  I'll have to take a closer look at how the
"get_flinalg_funcs" procedure works, and will probably try
rebuilding & reinstalling LAPACK, ATLAS, numpy and scipy from scratch.

Norm


More information about the SciPy-User mailing list