[SciPy-User] Scipy test failure

John Reid j.reid@mail.cryst.bbk.ac...
Wed Apr 7 09:13:40 CDT 2010



Bruce Southey wrote:
> First run tests in verbose mode that will at least identify the test. I 
> would guess that it is the eigenvalue tests especially given the usage 
> of GotoBlas.
> 
> 
> $ python2.5 -c "import scipy; scipy.test(verbose=10)"

These are the lines in the output that contain "ERROR":

test_dot (test_blas.TestFBLAS1Simple) ... ERROR
test_complex_dotc (test_blas.TestFBLAS1Simple) ... ERROR
test_complex_dotu (test_blas.TestFBLAS1Simple) ... ERROR




These are the lines that contain FAIL:

test_interpolate.TestInterp1D.test_nd_zero_spline ... KNOWNFAIL: 
zero-order splines fail for the last point
Check the actual implementation of zero-order spline interpolation. ... 
KNOWNFAIL: zero-order splines fail for the last point
test_gemm (test_blas.TestFBLAS3Simple) ... FAIL
test_gemm2 (test_blas.TestFBLAS3Simple) ... FAIL
test_ssygv_1 (test_gesv.TestSygv) ... FAIL
test_ssygv_2 (test_gesv.TestSygv) ... FAIL
test_ssygv_3 (test_gesv.TestSygv) ... FAIL
test_gemm (test_blas.TestFBLAS3Simple) ... FAIL


The last few lines of the output are:
test_simple_underdet (test_decomp.TestSVDVals) ... ok
test_simple_underdet_complex (test_decomp.TestSVDVals) ... ok
test_simple (test_decomp.TestSchur) ... ok
test_decomp.test_eigh('ordinary', 6, 'f', True, True, True, None) ... ok
test_decomp.test_eigh('general ', 6, 'f', True, True, True, None) ...


which I guess confirms your suspicion it is to do with eignevalues.

> 
>  From one of Robert's instructions:
> 
> $ gdb python2.5
> ...
> (gdb) run
> Starting program ...
> ... # Possibly another (gdb) prompt:
> (gdb) continue  #<- Type this.
> Python 2.6.2 ...
> 
> 
>>>>>>>  import numpy  #<- Type this and do whatever else is necessary to reproduce the crash.
>>>>        
> ... (gdb) bt # <- Type this. .... # <- Copy-paste these results here.

I'll try and see if I can do this



More information about the SciPy-User mailing list