[SciPy-User] Bottleneck

T J tjhnson@gmail....
Wed Dec 1 17:49:19 CST 2010


On Tue, Nov 30, 2010 at 7:04 PM, Keith Goodman <kwgoodman@gmail.com> wrote:
> I bumped the Bottleneck requirements from "NumPy, SciPy" to "NumPy
> 1.5.1+, SciPy 0.8.0+". I think that is fair to do for a brand new
> project.

If SciPy is only used in the benchmarks/tests, then why not make it an
optional benchmark/test that runs only if SciPy is present?
nose.SkipTest should be useful here.  I frequently run software on
machines that only have NumPy installed.


More information about the SciPy-User mailing list