[SciPy-User] Problems installing scipy on OS X 10.6 (Snow Leopard): libarpack

Uri Laserson laserson@mit....
Tue Dec 7 14:06:25 CST 2010


Hi all,

I am on a MacMini with Intel processor.  I just installed OS X 10.6 and the
latest Xcode that I could download, which included gcc 4.2.  I am using
python 2.7 built from source using homebrew.  I installed the gfortran 4.2.3
binaries from http://r.research.att.com/tools/.

I am trying to install numpy and scipy.  numpy installs fine with or without
switching to g++-4.0.  I have successfully installed it using pip and also
directly from source from the git repository.

Scipy is giving me errors on install (the same errors whether I use pip or
try the svn repository).  I installed it successfully yesterday on a new
Macbook Air using pip, after changing the symlinks to point to g++-4.0.
 However, today on my MacMini, I am getting errors after following the same
protocol.

The errors I am getting are here:
https://gist.github.com/732293

I also don't know why it's referencing temp.macosx-10.4-x86_64-2.7 while I
am on 10.6.

Please help!

Thanks!
Uri


...................................................................................
Uri Laserson
Graduate Student, Biomedical Engineering
Harvard-MIT Division of Health Sciences and Technology
M +1 917 742 8019
laserson@mit.edu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20101207/32a568ed/attachment-0001.html 


More information about the SciPy-User mailing list