[SciPy-User] probs making docs

Skipper Seabold jsseabold@gmail....
Wed Dec 15 10:05:37 CST 2010


On Wed, Dec 15, 2010 at 5:44 AM, George Nurser <gnurser@gmail.com> wrote:
> Hi,
> Just been making up
> numpy/ipython/scipy/matplotlib/pytables/netCDF4/cython etc on OS X
> 10.6 to go with python installed from the new 2.7.1. 10.6 x86_64/i386
> installer.
>
> Most things seem to work very straightforwardly -- numpy and scipy
> trunk seem in very good shape, and the new python installer makes
> everything much easier -- and numpy and matplotlib docs made OK, but
> I'm having a problem making up the scipy documentation.
>
> In the scipy/doc directory I initially tried
> make html
> It failed, looking for numpydoc.
> I therefore installed numpydoc.
>
> The output of make html is now
>
> mkdir -p build
> touch build/generate-stamp
> mkdir -p build/html build/doctrees
> LANG=C sphinx-build -b html -d build/doctrees   source build/html
> Running Sphinx v1.0.5
> Scipy (VERSION 0.10.dev) (RELEASE 0.10.0.dev)
>
> Extension error:
> Could not import extension plot_directive (exception: No module named
> plot_directive)
> make: *** [html] Error 1
>
> This seems strange, given that plot_directive.{py,pyc} are in the
> installed numpydoc directory
> /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpydoc-0.4-py2.7.egg/numpydoc
>

What numpy version?  This is an incompatibility with new sphinx (post
1.0 betas) and old numpy sphinx extensions.  You can either downgrade
sphinx or upgrade numpy.

http://projects.scipy.org/numpy/ticket/1489

I think you could really just drop in the newer numpy/doc/sphinxext/*
and it should work, but maybe not...

https://github.com/numpy/numpy/tree/master/doc/sphinxext

Skipper


More information about the SciPy-User mailing list