[SciPy-User] setup question

Yury V. Zaytsev yury@shurup....
Fri Dec 31 12:41:02 CST 2010


Hi!

On Fri, 2010-12-31 at 13:31 -0500, Nathaniel Polish wrote:

> As a computer scientist my urge is for the latest version but it seems that 
> there are some big issues in the 2.x to 3.x path.

Numpy / Scipy are just not fully py3k-ready yet. Pretty close, but not
yet. The situation with other libraries is similar. So if you are (1)
just starting (2) right now (and not in a year or two), go for what is
available in Ubuntu repositories at the moment.

I personally use interpreters from ActiveState and custom builds of
Numpy / Scipy in a virtualenv, but the reason for this is that I need to
keep the environment consistent among the cluster, desktop and personal
computers and also, bugs that I'm hitting were only fixed recently.

You'd better get to it when you will realize that you need it yourself.

P.S. Please keep the conversation on list.

P.P.S. Happy New Year to all the readers!
 
-- 
Sincerely yours,
Yury V. Zaytsev



More information about the SciPy-User mailing list