[SciPy-User] installing SciPy on Mac OS 10.6

David Cournapeau cournape@gmail....
Fri Feb 5 07:00:55 CST 2010


On Fri, Feb 5, 2010 at 9:21 PM, Gemma Atkinson <gemma.atkinson@gmail.com> wrote:
> Hi,
>
> I'm trying to install Scipy with little success. I already had numpy installed, but to make sure I was using the most current version, I installed it again. I got both Numy and Scipy from SVN. These are the commands I used:
>
> svn co http://svn.scipy.org/svn/numpy/trunk numpy
> svn co http://svn.scipy.org/svn/scipy/trunk scipy
>
> Then for each of these:
>
> python setup.py build
> sudo python setup.py install
>
> This seemed to work fine for numpy, but for Scipy I got this error with python setup.py build:
>
> from numpy.distutils.misc_util import get_numpy_include_dirs, get_info
> ImportError: cannot import name get_info

You are not using the numpy you just installed, but the one given with Mac OS X.

>
> (Full output pasted at end of message).
>
> I also tried installing Numpy and Scipy from the dmgs, but both failed saying that I need Python 2.6 (I have 2.6.1).

You should install the python from python.org. The dmgs do not work
with Apple python.

cheers,

David


More information about the SciPy-User mailing list