[SciPy-User] Install fail on Mac 10.6.2 in fftpack._fftpack

David Cournapeau david@silveregg.co...
Mon Feb 15 21:10:12 CST 2010


Adam Ginsburg wrote:
> Hi, I'm trying to get scipy running on my new Snow Leopard system.  I
> was able to get scipy built successfully yesterday, but not so much
> today.  I'd appreciate any assistance in getting scipy installed.
> 
> I built fftw with the following setup:
> ./configure CC="gcc -arch i386 -arch x86_64" CXX="g++ -arch i386 -arch
> x86_64" CPP="gcc -E" CXXCPP="g++ -E"
> make
> sudo make install
> 
> I've also tried multiple variations of architection for fftw (e.g. not
> using -arch i386 and passing no compiler flags). I built UMFTPACK
> following the instructions on: http://blog.hyperjeff.net/?p=160

Neither UMFPACK nor fftw are needed for scipy anymore, but that's not 
why your build fails.

You should unset LDFLAGS, CFLAGS, FFLAGS and CXXFLAGS when building 
scipy: setting them up does not do what you think it does,

cheers,

David


More information about the SciPy-User mailing list