[SciPy-User] scikits.sparse

Nils Wagner nwagner@iam.uni-stuttgart...
Sat Feb 20 04:05:56 CST 2010


  Hi,

I tried to install scikits.sparse.
It failed with

nwagner@linux-mogv:~/hg/scikits.sparse> python setup.py 
install --prefix=$HOME/local
/home/nwagner/local/lib64/python2.6/site-packages/setuptools-0.6c9-py2.6.egg/setuptools/command/sdist.py:4: 
UserWarning: Module pkg_resources was already imported 
from 
/home/nwagner/local/lib64/python2.6/site-packages/setuptools-0.6c9-py2.6.egg/pkg_resources.py, 
but 
/home/nwagner/local/lib64/python2.6/site-packages/distribute-0.6.4-py2.6.egg 
is being added to sys.path
/home/nwagner/local/lib64/python2.6/site-packages/setuptools-0.6c9-py2.6.egg/setuptools/command/sdist.py:4: 
UserWarning: Module setuptools was already imported from 
/home/nwagner/local/lib64/python2.6/site-packages/setuptools-0.6c9-py2.6.egg/setuptools/__init__.py, 
but 
/home/nwagner/local/lib64/python2.6/site-packages/distribute-0.6.4-py2.6.egg 
is being added to sys.path
/home/nwagner/local/lib64/python2.6/site-packages/setuptools-0.6c9-py2.6.egg/setuptools/command/sdist.py:4: 
UserWarning: Module site was already imported from 
/usr/lib64/python2.6/site.pyc, but 
/home/nwagner/local/lib64/python2.6/site-packages/distribute-0.6.4-py2.6.egg 
is being added to sys.path
/home/nwagner/local/lib64/python2.6/site-packages/Pyrex/Compiler/Errors.py:17: 
DeprecationWarning: BaseException.message has been 
deprecated as of Python 2.6
   self.message = message
running install
running bdist_egg
running egg_info
writing requirements to 
scikits.sparse.egg-info/requires.txt
writing scikits.sparse.egg-info/PKG-INFO
writing namespace_packages to 
scikits.sparse.egg-info/namespace_packages.txt
writing top-level names to 
scikits.sparse.egg-info/top_level.txt
writing dependency_links to 
scikits.sparse.egg-info/dependency_links.txt
writing requirements to 
scikits.sparse.egg-info/requires.txt
writing scikits.sparse.egg-info/PKG-INFO
writing namespace_packages to 
scikits.sparse.egg-info/namespace_packages.txt
writing top-level names to 
scikits.sparse.egg-info/top_level.txt
writing dependency_links to 
scikits.sparse.egg-info/dependency_links.txt
reading manifest file 
'scikits.sparse.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no previously-included files matching '*~' found 
anywhere in distribution
warning: no previously-included files matching '*.so' 
found anywhere in distribution
warning: no previously-included files matching '*.pyc' 
found anywhere in distribution
writing manifest file 
'scikits.sparse.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib.linux-x86_64-2.6
creating build/lib.linux-x86_64-2.6/scikits
copying scikits/__init__.py -> 
build/lib.linux-x86_64-2.6/scikits
creating build/lib.linux-x86_64-2.6/scikits/sparse
copying scikits/sparse/__init__.py -> 
build/lib.linux-x86_64-2.6/scikits/sparse
copying scikits/sparse/test_cholmod.py -> 
build/lib.linux-x86_64-2.6/scikits/sparse
running build_ext
cythoning scikits/sparse/cholmod.pyx to 
scikits/sparse/cholmod.c

Error converting Pyrex file to C:
------------------------------------------------------------
...
     #    0xA (alpha)
     #    0xB (beta)
     #    0xC (release candidate)
     #    0xF (final)

     char[] PY_VERSION
        ^
------------------------------------------------------------

/usr/lib64/python2.6/site-packages/Cython/Includes/python_version.pxd:31:8: 
Buffer types only allowed as function local variables

Error converting Pyrex file to C:
------------------------------------------------------------
...
     #    0xB (beta)
     #    0xC (release candidate)
     #    0xF (final)

     char[] PY_VERSION
     char[] PY_PATCHLEVEL_REVISION
        ^
------------------------------------------------------------

/usr/lib64/python2.6/site-packages/Cython/Includes/python_version.pxd:32:8: 
Buffer types only allowed as function local variables


How can I fix the problem ?
pyrexc --version
/home/nwagner/local/lib64/python2.6/site-packages/Pyrex/Compiler/Errors.py:17: 
DeprecationWarning: BaseException.message has been 
deprecated as of Python 2.6
   self.message = message
Pyrex version 0.9.8.5



                    Nils


More information about the SciPy-User mailing list