[SciPy-User] scikits.sparse

Nils Wagner nwagner@iam.uni-stuttgart...
Sat Feb 20 04:31:47 CST 2010


On Sat, 20 Feb 2010 11:22:46 +0100
  "Dag Sverre Seljebotn" <dagss@student.matnat.uio.no> 
wrote:
>>   Hi,
>>
>> I tried to install scikits.sparse.
>> It failed with
> ..> Error converting Pyrex file to C:
>> ------------------------------------------------------------
>> ...
>>      #    0xB (beta)
>>      #    0xC (release candidate)
>>      #    0xF (final)
>>
>>      char[] PY_VERSION
>>      char[] PY_PATCHLEVEL_REVISION
>>         ^
>> ------------------------------------------------------------
>>
>> /usr/lib64/python2.6/site-packages/Cython/Includes/python_version.pxd:32:8:
>> Buffer types only allowed as function local variables
>>
>>
>> How can I fix the problem ?
>> pyrexc --version
>> /home/nwagner/local/lib64/python2.6/site-packages/Pyrex/Compiler/Errors.py:17:
>> DeprecationWarning: BaseException.message has been
>> deprecated as of Python 2.6
>>    self.message = message
>> Pyrex version 0.9.8.5
> 
> 
> The Cython version is what is relevant here, Pyrex is 
>not used (regardless
> of what distutils claims!). And it turns out that this 
>error is caused by
> a too old version of Cython -- upgrade your Cython and 
>that should fix it.
> 
> Dag Sverre
> 
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user

I am using

cython --version
Cython version 0.10.3
  
That version is shipped with Open SuSe 11.2 which is quite 
new.

What is needed by scikits.sparse ?

Nils


More information about the SciPy-User mailing list