[SciPy-User] Problem with self-built numpy 1.4.1 on kubuntu lucid

Scott Sinclair scott.sinclair.za@gmail....
Wed Jul 21 07:29:33 CDT 2010


>On 21 July 2010 14:02, Yosef Meller <yosefmel@post.tau.ac.il> wrote:
> I'm trying to build numpy 1.4.1 on an Ubuntu Lucid system. I've done this
> recently on a similar system and it went fine. But here, the build finishes fine,
> but the tests give me errors (see below).
>
> --------------
> In [3]: import numpy
>
> In [4]: numpy.test()
> Running unit tests for numpy
> NumPy version 1.4.1
> NumPy is installed in /usr/local/lib/python2.6/dist-packages/numpy
> Python version 2.6.5 (r265:79063, Apr 16 2010, 13:57:41) [GCC 4.4.3]
> nose version 0.11.1
> .EEEEEEEEEEE..........................................................................................................................................SSSSSSSS................................................................................................................................................................................................................................................................................SSS...........................................................................................................................................................................................................................................K........................................................................................K......................K.K......................................................................................................EEEEEEE..................................................................................................
>  .............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
>  ..........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
> ======================================================================
> ERROR: test_creation (test_datetime.TestDateTime)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>  File "/usr/local/lib/python2.6/dist-
> packages/numpy/core/tests/test_datetime.py", line 10, in test_creation
>    dt1 = np.dtype('M8[750%s]'%unit)
> TypeError: data type not understood

NumPy 1.4.1 shouldn't have 'numpy/core/tests/test_datetime.py'. It
looks like you have some files left over from an old installation
(maybe 1.4.0?).

Make sure that 1) you remove the build sub-directory from wherever
you've unpacked the source code before building again and 2) you
completely remove the contents of
/usr/local/lib/python2.6/dist-packages/numpy before installing.

Cheers,
Scott


More information about the SciPy-User mailing list