[SciPy-User] what's the combination of python, scipy, numpy, and MinGW for Weave to work?

Ming Gu minggu2@gmail....
Wed Jul 21 22:19:20 CDT 2010


Hi guys,

I wonder what's the combination of versions for python, scipy, numpy, and
MinGW for Weave to work?

My current systems keeps giving the following error:

Traceback (most recent call last):
  File "<pyshell#1>", line 1, in <module>
    test_weave_3(100)
  File "C:\temp\test_weave_3.py", line 54, in test_weave_3
    weave.inline(code1, ['m', 's', 'm2', 'm3'],
type_converters=converters.blitz, compiler='gcc', verbose = 2)
  File "C:\Python26\lib\site-packages\scipy\weave\inline_tools.py", line
355, in inline
    **kw)
  File "C:\Python26\lib\site-packages\scipy\weave\inline_tools.py", line
482, in compile_function
    verbose=verbose, **kw)
  File "C:\Python26\lib\site-packages\scipy\weave\ext_tools.py", line 367,
in compile
    verbose = verbose, **kw)
  File "C:\Python26\lib\site-packages\scipy\weave\build_tools.py", line 273,
in build_extension
    setup(name = module_name, ext_modules = [ext],verbose=verb)
  File "C:\Python26\lib\site-packages\numpy\distutils\core.py", line 186, in
setup
    return old_setup(**new_attr)
  File "C:\Python26\lib\distutils\core.py", line 162, in setup
    raise SystemExit, error
CompileError: error: Bad file descriptor

Here is the result from weave.test()
Running unit tests for scipy.weave
NumPy version 1.4.1
NumPy is installed in C:\Python26\lib\site-packages\numpy
SciPy version 0.8.0rc3
SciPy is installed in C:\Python26\lib\site-packages\scipy
Python version 2.6.5 (r265:79096, Mar 19 2010, 21:48:26) [MSC v.1500 32 bit
(Intel)]
nose version 0.11.2

Thanks a lot!!!

Ming
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20100721/4785c599/attachment.html 


More information about the SciPy-User mailing list