[SciPy-User] checklist script error

Christopher Burns chris.d.burns@gmail....
Fri Jun 25 11:43:51 CDT 2010


Hey Kevin,

Setuptools can be installed from pypi:

  http://pypi.python.org/pypi/setuptools/0.6c8

Mayavi is more of a challenge due to it's dependencies.  You have two
choices here:

1) The Easy Way:  Installing one of the all-in-one distributions like
EPD or pythonxy.  These will install all the dependencies (and then
sum) in a new python installation.

  http://www.enthought.com/products/epd.php
  http://www.pythonxy.com/

2) The Hard Way:  Installing mayavi and it's dependencies yourself.

Download mayavi from pypi:
  http://pypi.python.org/pypi/Mayavi/3.3.2

Mayavi depends on VTK and wxPython, there are links for these under
the Prerequisites section on the
pypi page.  For wxPython, there is a dmg installer in their downloads page.

It's worth a simple check to see if you have it installed already.  If
you do, this command will print out a version number:
    python -c "import wx; print wx.__version__"

There is no binary for VTK, so you need to download the source
(tarball or zip) and build it using CMake.  This can go easy or hard
depending on your comfort level with building C code.  There are
compilation instructions in the VTK Readme.html.

Chris

On Fri, Jun 25, 2010 at 3:34 AM, Kevin <lindsay@stsci.edu> wrote:
> The entire output of that script upon attempting to run it is the following:
>
> Running tests:
> __main__.test_imports('setuptools', None) ... ERROR
> __main__.test_imports('IPython', None) ... MOD: IPython, version: 0.9.1
> ok
> __main__.test_imports('numpy', None) ... MOD: numpy, version: 1.3.0
> ok
> __main__.test_imports('scipy', None) ... MOD: scipy, version: 0.7.1
> ok
> __main__.test_imports('scipy.io', None) ... MOD: scipy.io, version: *no info*
> ok
> __main__.test_imports('matplotlib', <function validate_mpl at 0x6d5f70>) ... MOD: matplotlib, version: 0.99.0
> ok
> __main__.test_imports('pylab', None) ... MOD: pylab, version: *no info*
> ok
> __main__.test_imports('enthought.mayavi.api', None) ... ERROR
> __main__.test_loadtxt(array([[ 0.,  1.], ... ok
> __main__.test_loadtxt(array([('M', 21, 72.0), ('F', 35, 58.0)], ... ok
> __main__.test_loadtxt(array([ 1.,  3.]), array([ 1.,  3.])) ... ok
> __main__.test_loadtxt(array([ 2.,  4.]), array([ 2.,  4.])) ... ok
> Simple plot generation. ... ok
> Plots with math ... ok
>
> ======================================================================
> ERROR: __main__.test_imports('setuptools', None)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>  File "/usr/stsci/pyssg/2.5.4/nose/case.py", line 183, in runTest
>    self.test(*self.arg)
>  File "intro_tut_checklist.py", line 95, in check_import
>    exec "import %s as m" % mnames
>  File "<string>", line 1, in <module>
> ImportError: No module named setuptools
>
> ======================================================================
> ERROR: __main__.test_imports('enthought.mayavi.api', None)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>  File "/usr/stsci/pyssg/2.5.4/nose/case.py", line 183, in runTest
>    self.test(*self.arg)
>  File "intro_tut_checklist.py", line 95, in check_import
>    exec "import %s as m" % mnames
>  File "<string>", line 1, in <module>
> ImportError: No module named enthought.mayavi.api
>
> ----------------------------------------------------------------------
> Ran 14 tests in 10.766s
>
> FAILED (errors=2)
> Cleanup - removing temp directory: /Users/lindsay/tmp-testdata-etwtf9
>
> ***************************************************************************
>                           TESTS FINISHED
> ***************************************************************************
>
> If the printout above did not finish in 'OK' but instead says 'FAILED', copy
> and send the *entire* output, including the system information below, for help.
> We'll do our best to assist you.  You can send your message to the Scipy user
> mailing list:
>
>    http://mail.scipy.org/mailman/listinfo/scipy-user
>
> but feel free to also CC directly:  cburns at berkeley dot edu
>
>
> ==================
> System information
> ==================
> os.name      : posix
> os.uname     : ('Darwin', 'mooseman.home', '9.8.0', 'Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386', 'i386')
> platform     : darwin
> platform+    : Darwin-9.8.0-i386-32bit
> prefix       : /usr/stsci/pyssg/Python-2.5.4
> exec_prefix  : /usr/stsci/pyssg/Python-2.5.4
> executable   : /usr/stsci/pyssg/Python-2.5.4//bin/python
> version_info : (2, 5, 4, 'final', 0)
> version      : 2.5.4 (r254:67916, Nov  6 2009, 11:35:14)
> [GCC 4.0.1 (Apple Inc. build 5465)]
> ==================
>


More information about the SciPy-User mailing list