[SciPy-User] Compiling scipy.sparse.sparsetools extension throws g++ internal error

Diederik van Liere dvanliere@gmail....
Mon Mar 8 21:10:10 CST 2010


Dear scipy-user members,


I am trying to build Scipy for my 32bit Redhat server and I am running into
serious trouble, both with scipy 0.7.1 and the latest SVN version.

I get the following error:

building 'scipy.sparse.sparsetools._csr' extension
compiling C++ sources
C compiler: g++ -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall
-fPIC

creating build/temp.linux-i686-2.6/scipy/sparse/sparsetools
compile options:
'-I/usr/local/lib/python2.6/site-packages/numpy/core/include
-I/usr/local/include/python2.6 -c'
g++: scipy/sparse/sparsetools/csr_wrap.cxx
g++: Internal error: Terminated (program cc1plus)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
g++: Internal error: Terminated (program cc1plus)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
error: Command "g++ -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3
-Wall -fPIC -I/usr/local/lib/python2.6/site-packages/numpy/core/include
-I/usr/local/include/python2.6 -c scipy/sparse/sparsetools/csr_wrap.cxx -o
build/temp.linux-i686-2.6/scipy/sparse/sparsetools/csr_wrap.o" failed with
exit status 1

and I really don't know how to fix this. I have tried both Numpy 1.3.0 and
the latest Numpy SVN version but to no avail. I hope someone can point me in
the right direction.

Thanks so much,

Best regards,


Diederik
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20100308/a79401a2/attachment.html 


More information about the SciPy-User mailing list