[SciPy-User] How to install scipy for opensuse 10.3?

Lam Waiman gunbuster363@gmail....
Fri Mar 26 07:33:52 CDT 2010


I added the above linkas a repository.
I tried to installed scipy, then hell lots of dependencies problems
come out........
one of them is scipy need python 2.5........non-sense, I am using
python 2.6 already.......

what is your opinion?

2010/3/26 Joe Kington <jkington@wisc.edu>:
> Gah, meant to link to the base repo, but I managed to have the text show the
> base repo, and the link have the 64-bit repo...
> Here you go:
> http://download.opensuse.org/repositories/science:/ScientificLinux/SLE_10/
>
> On Thu, Mar 25, 2010 at 2:00 PM, Joe Kington <jkington@wisc.edu> wrote:
>>
>> It's rather dated (scipy 0.6) , but I think this repo definitely has scipy
>> and should be compatible with 10.3.
>> http://download.opensuse.org/repositories/science:/ScientificLinux/SLE_10/
>> Hope that helps,
>> -Joe
>>
>> On Thu, Mar 25, 2010 at 10:29 AM, Lam Waiman <gunbuster363@gmail.com>
>> wrote:
>>>
>>> But I cannot see scipy in that folder........
>>> And I don't want to upgrade to 11.2 because I am not sure if my package
>>> in 10.3 still works.....I don't want to risk now....
>>>
>>> 2010/3/25 Joe Kington <jkington@wisc.edu>
>>>>
>>>> I'm pretty certain scipy and numpy are in the repos for OpenSuse 10.3.
>>>> (or at least they were a few years ago... Is there some reason you can't
>>>> upgrade to 11.2? They're definitely in the repos for 11.0, 11.1, and 11.2)
>>>>
>>>> Do you have the science repos enabled?  They may have dropped them for
>>>> 10.x, but you can always add the SEL_10 versions.  They should be
>>>> compatible. http://download.opensuse.org/repositories/science/SLE_10/
>>>>
>>>> Hope that helps,
>>>> -Joe
>>>>
>>>> On Thu, Mar 25, 2010 at 4:31 AM, Lam Waiman <gunbuster363@gmail.com>
>>>> wrote:
>>>>>
>>>>> Dear all,
>>>>>               I want to install scipy for python usage. I see the
>>>>> installation isreally complex, can someone give on some advice on it?
>>>>> My system, opensuse 10.3 (i586)
>>>>> I am using python 2.6.4
>>>>> when I see the doc, it said it require LAPACK to be installed,
>>>>> then I download lapack and see inside, it also require lots of things
>>>>> including fortran compiler
>>>>> and I don't know whether the gcc42-fortran compiler in my comp is ok.
>>>>> I try to dl the g77 compiler, which someone said I will need it for
>>>>> LAPACK
>>>>> then it g77 only works with a gcc compiler of version 2.8, but I am
>>>>> using a gcc compiler of version 4.2.
>>>>> SO COMPLEX!
>>>>> Looking forwards to your reply, thanks.
>>>>> Raymond
>>>>> _______________________________________________
>>>>> SciPy-User mailing list
>>>>> SciPy-User@scipy.org
>>>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> SciPy-User mailing list
>>>> SciPy-User@scipy.org
>>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>>
>>>
>>>
>>> _______________________________________________
>>> SciPy-User mailing list
>>> SciPy-User@scipy.org
>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>
>>
>>
>> _______________________________________________
>> SciPy-User mailing list
>> SciPy-User@scipy.org
>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>
>
>
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
>
>


More information about the SciPy-User mailing list