[SciPy-User] How to install scipy for opensuse 10.3?

Lam Waiman gunbuster363@gmail....
Fri Mar 26 07:38:11 CDT 2010


See the conflict list:
-------------------------------------------------
#### YaST2 conflicts list - generated 2010-03-26 20:47:14 ####

libblas3 cannot be installed due to missing dependencies
    There are no installable providers of libgfortran.so.1 for
libblas3-3.2.1-10.1.i586[rere]
    === libblas3-3.2.1-10.1.i586[rere] ===
        libblas3-3.2.1-10.1.i586[rere] will be installed by the user.
        libgcc42-4.2.1_20070724-17.i586 is needed by
libblas3-3.2.1-10.1.i586[rere] (libgcc_s.so.1)
        libblas3-3.2.1-10.1.i586[rere] is needed by
liblapack3-3.2.1-10.1.i586[rere] (libblas.so.3)
    (null)
    Conflict Resolution:
        ( ) do not install libblas3
        ( ) Ignore this requirement just here
liblapack3 cannot be installed due to missing dependencies
    There are no installable providers of libgfortran.so.1 for
liblapack3-3.2.1-10.1.i586[rere]
    === liblapack3-3.2.1-10.1.i586[rere] ===
        liblapack3-3.2.1-10.1.i586[rere] will be installed by the user.
        libblas3-3.2.1-10.1.i586[rere] is needed by
liblapack3-3.2.1-10.1.i586[rere] (libblas.so.3)
        liblapack3-3.2.1-10.1.i586[rere] is needed by
python-scipy-0.6.0-6.4.i586[rere] (liblapack.so.3)
    (null)
    Conflict Resolution:
        ( ) do not install liblapack3
        ( ) Ignore this requirement just here
python-scipy cannot be installed due to missing dependencies
    There are no installable providers of libgfortran.so.1 for
python-scipy-0.6.0-6.4.i586[rere]
    === python-scipy-0.6.0-6.4.i586[rere] ===
        python-scipy-0.6.0-6.4.i586[rere] will be installed by the user.
        libstdc++42-4.2.1_20070724-17.i586 is needed by
python-scipy-0.6.0-6.4.i586[rere] (libstdc++.so.6)
        fftw3-3.1.2-62.i586 is needed by
python-scipy-0.6.0-6.4.i586[rere] (libfftw3.so.3)
        liblapack3-3.2.1-10.1.i586[rere] is needed by
python-scipy-0.6.0-6.4.i586[rere] (liblapack.so.3)
        python-2.5.1-39.8.i586 is needed by
python-scipy-0.6.0-6.4.i586[rere] (python == 2.5.1-39.8)
    (null)
    Conflict Resolution:
        ( ) do not install python-scipy
        ( ) Ignore this requirement just here

#### YaST2 conflicts list END ###

2010/3/26 Lam Waiman <gunbuster363@gmail.com>:
> I added the above linkas a repository.
> I tried to installed scipy, then hell lots of dependencies problems
> come out........
> one of them is scipy need python 2.5........non-sense, I am using
> python 2.6 already.......
>
> what is your opinion?
>
> 2010/3/26 Joe Kington <jkington@wisc.edu>:
>> Gah, meant to link to the base repo, but I managed to have the text show the
>> base repo, and the link have the 64-bit repo...
>> Here you go:
>> http://download.opensuse.org/repositories/science:/ScientificLinux/SLE_10/
>>
>> On Thu, Mar 25, 2010 at 2:00 PM, Joe Kington <jkington@wisc.edu> wrote:
>>>
>>> It's rather dated (scipy 0.6) , but I think this repo definitely has scipy
>>> and should be compatible with 10.3.
>>> http://download.opensuse.org/repositories/science:/ScientificLinux/SLE_10/
>>> Hope that helps,
>>> -Joe
>>>
>>> On Thu, Mar 25, 2010 at 10:29 AM, Lam Waiman <gunbuster363@gmail.com>
>>> wrote:
>>>>
>>>> But I cannot see scipy in that folder........
>>>> And I don't want to upgrade to 11.2 because I am not sure if my package
>>>> in 10.3 still works.....I don't want to risk now....
>>>>
>>>> 2010/3/25 Joe Kington <jkington@wisc.edu>
>>>>>
>>>>> I'm pretty certain scipy and numpy are in the repos for OpenSuse 10.3.
>>>>> (or at least they were a few years ago... Is there some reason you can't
>>>>> upgrade to 11.2? They're definitely in the repos for 11.0, 11.1, and 11.2)
>>>>>
>>>>> Do you have the science repos enabled?  They may have dropped them for
>>>>> 10.x, but you can always add the SEL_10 versions.  They should be
>>>>> compatible. http://download.opensuse.org/repositories/science/SLE_10/
>>>>>
>>>>> Hope that helps,
>>>>> -Joe
>>>>>
>>>>> On Thu, Mar 25, 2010 at 4:31 AM, Lam Waiman <gunbuster363@gmail.com>
>>>>> wrote:
>>>>>>
>>>>>> Dear all,
>>>>>>               I want to install scipy for python usage. I see the
>>>>>> installation isreally complex, can someone give on some advice on it?
>>>>>> My system, opensuse 10.3 (i586)
>>>>>> I am using python 2.6.4
>>>>>> when I see the doc, it said it require LAPACK to be installed,
>>>>>> then I download lapack and see inside, it also require lots of things
>>>>>> including fortran compiler
>>>>>> and I don't know whether the gcc42-fortran compiler in my comp is ok.
>>>>>> I try to dl the g77 compiler, which someone said I will need it for
>>>>>> LAPACK
>>>>>> then it g77 only works with a gcc compiler of version 2.8, but I am
>>>>>> using a gcc compiler of version 4.2.
>>>>>> SO COMPLEX!
>>>>>> Looking forwards to your reply, thanks.
>>>>>> Raymond
>>>>>> _______________________________________________
>>>>>> SciPy-User mailing list
>>>>>> SciPy-User@scipy.org
>>>>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> SciPy-User mailing list
>>>>> SciPy-User@scipy.org
>>>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> SciPy-User mailing list
>>>> SciPy-User@scipy.org
>>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>>
>>>
>>>
>>> _______________________________________________
>>> SciPy-User mailing list
>>> SciPy-User@scipy.org
>>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>>
>>
>>
>> _______________________________________________
>> SciPy-User mailing list
>> SciPy-User@scipy.org
>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>
>>
>


More information about the SciPy-User mailing list