[SciPy-User] problems installing scipy on cygwin

James McCormac jmccormac01@qub.ac...
Wed Nov 17 20:16:19 CST 2010


Hi Guys,
I've spent the last while following the page online for installing scipy
on my windows machine via cygwin. I only want to use scipy from within
cygwin.

I have built numpy-1.5.0 and it is working ok, although when i try the
numpy.test() i get an error saying 'need nose >= 0.1.0 for tests' but
everything else seems fine.

I have also built the ATLAS and LAPACK files following the instructions
online. I added them to a file like it suggested and added this location
to the site.cfg in numpy. When i do a numpy.show_config() there are a list
of libraries shown fine.

I also added this site.cfg file to the root of the scipy-0.8.0 source
directory. When i then try to build scipy-0.8.0 i get the errors in
error.txt attached. I've also attached the site.cfg file too just incase.

Has anyone successfully got scipy/numpy to work on cygwin?

I am using cygwin version 1.7.7 and python 2.6.5. When i start python the
GCC version is 4.3.4. If i am missing any info please let me know. I'm
keen to get this working asap.

Thanks in advance!

James McCormac
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: error.txt
Url: http://mail.scipy.org/pipermail/scipy-user/attachments/20101118/0fb745b0/attachment-0001.txt 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: site.cfg
Type: application/octet-stream
Size: 83 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/scipy-user/attachments/20101118/0fb745b0/attachment-0001.obj 


More information about the SciPy-User mailing list