[SciPy-User] /usr/bin/ld: cannot find -lnpymath AND ImportError: cannot import name asstr and

Skipper Seabold jsseabold@gmail....
Tue Nov 23 19:38:55 CST 2010


On Tue, Nov 23, 2010 at 8:31 PM, Peter Tittmann <ptittmann@gmail.com> wrote:
> Python 2.6.6 (r266:84292, Oct  9 2010, 12:24:52)
> [GCC 4.4.5] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import numpy as np
>>>> np.__version__
> '1.4.1'
>

I don't think this version of numpy as the Python 3 compatibility
functions (here: numpy.compat.asstr).  You might also try upgrading
your numpy first.

Is the current scipy trunk expected to be able to build against older numpy?

Skipper

> --
> Peter Tittmann
>
> On Tuesday, November 23, 2010 at 5:28 PM, Skipper Seabold wrote:
>
> On Tue, Nov 23, 2010 at 8:13 PM, Peter Tittmann <ptittmann@gmail.com> wrote:
>
> Hi All,
> it appears that optimize.curve_fit is not a part of the current Debian
> squeeze binary (0.7.2+dfsg1-1) so ive been attempting to build  from source
> with a lot of trouble. When building using the archive (scipy-0.8.0.tar.gz)
> i get the following error whihc clamis to have been addressed by this
> bug http://projects.scipy.org/numpy/ticket/1194 :
> /usr/bin/ld: cannot find -lnpymath
> collect2: ld returned 1 exit status
> /usr/bin/ld: cannot find -lnpymath
> collect2: ld returned 1 exit status
> error: Command "/usr/bin/gfortran -Wall -Wall -shared
> build/temp.linux-x86_64-2.6/scipy/special/_cephesmodule.o
> build/temp.linux-x86_64-2.6/scipy/special/amos_wrappers.o
> build/temp.linux-x 86_64-2. 6/scipy/special/specfun_wrappers.o
> build/temp.linux-x86_64-2.6/scipy/special/toms_wrappers.o
> build/temp.linux-x86_64-2.6/scipy/spe cial/cdf _wrappers.o
> build/temp.linux-x86_64-2.6/scipy/special/ufunc_extras.o
> -L/usr/lib/pymodules/python2.6/numpy/core/lib -Lbuild/temp.linux-x86_64-2.6
> -lsc_amos -lsc_toms -lsc_c_misc -lsc_cephes -lsc_mach -lsc_cdf -lsc_specfun
> -lnpymath -lm -lgfortran -o
> build/lib.linux-x86_64-2.6/scipy/special/_cephes.so" failed with exit status
> 1
> then attempting to build from the svn repository the following error which i
> can't even find reference to in google:
>
> $:~/Downloads/scipy$ sudo python setup.py install
> Traceback (most recent call last):
>   File "setup.py", line 85, in
>     FULLVERSION += svn_version()
>   File "setup.py", line 58, in svn_version
>     from numpy.compat import asstr
> ImportError: cannot import name asstr
>
> < /div>
>
> What version of numpy for this build?
>
> Maybe i'm stuck in some sort of pervasive metaphysical dysfunction, or maybe
> its something simple and one of you clever folks can point me in the right
> direction. (i hope its the latter)
> system is
> Debian squeeze amd x64
> thanks,
> Peter
>
> --
> Peter Tittmann
>
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
>
>
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
>
>
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
>
>


More information about the SciPy-User mailing list