[SciPy-User] /usr/bin/ld: cannot find -lnpymath AND ImportError: cannot import name asstr and

Pauli Virtanen pav@iki...
Tue Nov 23 19:45:41 CST 2010


On Tue, 23 Nov 2010 20:38:55 -0500, Skipper Seabold wrote:
[clip]
> I don't think this version of numpy as the Python 3 compatibility
> functions (here: numpy.compat.asstr).  You might also try upgrading your
> numpy first.
> 
> Is the current scipy trunk expected to be able to build against older
> numpy?

The SVN version of Scipy requires Numpy 1.5.

0.8.0 is buildable with Numpy 1.4.1. I suspect the problems OP is having 
are due to some changes Debian has made in their packages. Or perhaps the 
OP has environment variables LDFLAGS or CFLAGS set. Difficult to say 
without seeing the build log.

-- 
Pauli Virtanen



More information about the SciPy-User mailing list