[SciPy-User] /usr/bin/ld: cannot find -lnpymath AND ImportError: cannot import name asstr and

Peter Tittmann ptittmann@gmail....
Tue Nov 23 19:58:43 CST 2010


        
        Build log is attached. Thanks for the quick response!This showed up on the command line as well:Warning: No configuration returned, assuming unavailable./usr/lib/pymodules/python2.6/numpy/distutils/command/config.py:394: DeprecationWarning: +++++++++++++++++++++++++++++++++++++++++++++++++Usage of get_output is deprecated: please do not use it anymore, and avoid configuration checks involving running executable on the target machine.+++++++++++++++++++++++++++++++++++++++++++++++++  DeprecationWarning)/usr/lib/pymodules/python2.6/numpy/distutils/system_info.py:452: UserWarning:     UMFPACK sparse solver (http://www.cise.ufl.edu/research/sparse/umfpack/)    not found. Directories to search for the libraries can be specified in the    numpy/distutils/site.cfg file (section [umfpack]) or by setting    the UMFPACK environment variable.  warnings.warn(self.notfounderror.__doc__)error: Command "/usr/bin/gfortran -Wall -Wall -shared build/temp.linux-x86_64-2.6/sc
ipy/special/_cephesmodule.o build/temp.linux-x86_64-2.6/scipy/special/amos_wrappers.o build/temp.linux-x86_64-2.6/scipy/special/specfun_wrappers.o build/temp.linux-x86_64-2.6/scipy/special/toms_wrappers.o build/temp.linux-x86_64-2.6/scipy/special/cdf_wrappers.o build/temp.linux-x86_64-2.6/scipy/special/ufunc_extras.o -L/usr/lib/pymodules/python2.6/numpy/core/lib -Lbuild/temp.linux-x86_64-2.6 -lsc_amos -lsc_toms -lsc_c_misc -lsc_cephes -lsc_mach -lsc_cdf -lsc_specfun -lnpymath -lm -lgfortran -o build/lib.linux-x86_64-2.6/scipy/special/_cephes.so" failed with exit status 1
        
        -- Peter Tittmann
		
		
        On Tuesday, November 23, 2010 at 5:45 PM, Pauli Virtanen wrote:
        
            On Tue, 23 Nov 2010 20:38:55 -0500, Skipper Seabold wrote:[clip] I don't think this version of numpy as the Python 3 compatibility functions (here: numpy.compat.asstr).  You might also try upgrading your numpy first.  Is the current scipy trunk expected to be able to build against older numpy?The SVN version of Scipy requires Numpy 1.5.0.8.0 is buildable with Numpy 1.4.1. I suspect the problems OP is having are due to some changes Debian has made in their packages. Or perhaps the OP has environment variables LDFLAGS or CFLAGS set. Difficult to say without seeing the build log.-- Pauli Virtanen_______________________________________________SciPy-User mailing listSciPy-User@scipy.orghttp://mail.scipy.org/mailman/listinfo/scipy-user
			
			
			
			
        
		
		
    

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20101123/4eedd1ad/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: scipy080_numpy141_build
Type: application/octet-stream
Size: 17995 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/scipy-user/attachments/20101123/4eedd1ad/attachment-0001.obj 


More information about the SciPy-User mailing list