[SciPy-User] /usr/bin/ld: cannot find -lnpymath AND ImportError: cannot import name asstr and

David david@silveregg.co...
Wed Nov 24 00:53:54 CST 2010


On 11/24/2010 10:13 AM, Peter Tittmann wrote:
> Hi All,
>
> it appears that optimize.curve_fit is not a part of the current Debian
> squeeze binary (0.7.2+dfsg1-1) so ive been attempting to build from
> source with a lot of trouble. When building using the archive
> (scipy-0.8.0.tar.gz) i get the following error whihc clamis to have been
> addressed by this bug http://projects.scipy.org/numpy/ticket/1194 :

The short answer is that numpy packaged by debian is broken.

Long answer: you need to install numpy from sources by yourself (1.4.1 
is fine), and then scipy on top of it.

With python 2.6, a simple way is to install everything as --user, so you 
don't need to mess with PYTHONPATH and whatnot:

	- go into numpy sources and do: python setup.py install --user
	- go into scipy sources and do: python setup.py install --user

cheers,

David


More information about the SciPy-User mailing list