[SciPy-User] /usr/bin/ld: cannot find -lnpymath AND ImportError: cannot import name asstr and

David david@silveregg.co...
Wed Nov 24 01:03:46 CST 2010


On 11/24/2010 03:53 PM, David wrote:
> On 11/24/2010 10:13 AM, Peter Tittmann wrote:
>> Hi All,
>>
>> it appears that optimize.curve_fit is not a part of the current Debian
>> squeeze binary (0.7.2+dfsg1-1) so ive been attempting to build from
>> source with a lot of trouble. When building using the archive
>> (scipy-0.8.0.tar.gz) i get the following error whihc clamis to have been
>> addressed by this bug http://projects.scipy.org/numpy/ticket/1194 :
>
> The short answer is that numpy packaged by debian is broken.

This has actually alread been reported: 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=596987

cheers,

David


More information about the SciPy-User mailing list