[SciPy-User] [SciPy-user] trouble installing scipy on Mac10.6.4 with Python2.7

MDenno mgdenno@gmail....
Thu Oct 28 21:31:19 CDT 2010


Hello:

Sorry to piggy-back on an existing thread but I am wondering the current
status of scipy and python 2.7 is as discussed below.

Thanks,

Matt


Ralf Gommers-2 wrote:
> 
> On Thu, Sep 16, 2010 at 8:52 AM, Eric Schow <eschow@uci.edu> wrote:
> 
>> Hi all,
>>
>> I am new to Python and NumPy/SciPy, and I'm having trouble getting scipy
>> installed on my machine.
>>
>> I am working on an Intel Mac running OS 10.6.4, and I've recently updated
>> the python installation to 2.7. I have installed NumPy 1.5.0, and I am
>> trying to install scipy 0.8.0, which I downloaded as a tarball from
>> sourceforge.
> 
> 
> 0.8.0 was not fully working with 2.7, some fixes went into trunk after the
> release. please use a recent svn checkout.
> 
> I have gcc 4.2.1 installed (through Xcode), although the build process
> seems
>> to be calling gcc4.0. I have gfortran, which I just re-installed from
>> http://r.research.att.com/tools/, as suggested in the installation notes
>> that came with scipy. The problem seems to be with gfortran, although I
>> admit I'm a little out of my league as I try to troubleshoot this one.
>> The
>> log file is attached. Finally, I initiated the build with this command:
>>
>> LDFLAGS="-arch x86_64" FFLAGS="-arch x86_64" python setup.py build
>>
> 
> This doesn't extend but overrides the build flags, that's how distutils
> works. With numscons this should work as advertised (although it looks
> like
> numscons has some issue with 2.7 ATM). I've just added a warning that
> describes this better at http://www.scipy.org/Installing_SciPy/Mac_OS_X,
> because people keep running into this issue.
> 
> 
>> Any help on this issue will be appreciated. BTW, I would prefer to go
>> with
>> Python 2.7 (as opposed to 2.6, for which there is a .dmg available)
>> because
>> of its purported increased compatibility with Python 3.x.
>>
> 
> I'd go with 2.6 for now, that's properly tested and binaries are
> available.
> Any 2.7 issues should be worked out soon, but at the moment YMMV.
> 
> Sorry for the very slow reply.
> 
> Cheers,
> Ralf
> 
> 
>> Thanks a mole,
>>
>> Eric
>>
>>
>>
>>
>>
>>
>> _______________________________________________
>> SciPy-User mailing list
>> SciPy-User@scipy.org
>> http://mail.scipy.org/mailman/listinfo/scipy-user
>>
>>
> 
> _______________________________________________
> SciPy-User mailing list
> SciPy-User@scipy.org
> http://mail.scipy.org/mailman/listinfo/scipy-user
> 
> 

-- 
View this message in context: http://old.nabble.com/trouble-installing-scipy-on-Mac10.6.4-with-Python2.7-tp29807543p30082360.html
Sent from the Scipy-User mailing list archive at Nabble.com.



More information about the SciPy-User mailing list