[SciPy-User] numpy and mkl/10.3

Brock Palen brockp@umich....
Tue Aug 16 10:31:30 CDT 2011


I am trying to build the current numpy with mkl/10.3  Many library names have changed and I would like to get the effective link line of:

 -Wl,--start-group  $(MKLROOT)/lib/intel64/libmkl_intel_lp64.a $(MKLROOT)/lib/intel64/libmkl_sequential.a $(MKLROOT)/lib/intel64/libmkl_core.a -Wl,--end-group -lpthread

I have also tried doing the normal dynamic library link of:
-L/usr/caen/intel-12.0/mkl/lib/intel64 -lmkl_intel_lp64 -lmkl_sequential -lmkl_core -lpthread

I have tried messing about in site.cfg and following an intel forum post I set BLAS and LAPACK to these values with an empty site.cfg,

No mater what I get:
F2PY Version 2
blas_opt_info:
blas_mkl_info:
  NOT AVAILABLE

And it picks up redhats blas/lapack which I don't want to use (very very slow).

Any tips for why numpy does not build with MKL 10.3 ?



Brock Palen
www.umich.edu/~brockp
Center for Advanced Computing
brockp@umich.edu
(734)936-1985





More information about the SciPy-User mailing list