[SciPy-User] error: command 'swig' failed with exit status 1

Ralf Gommers ralf.gommers@googlemail....
Thu Mar 3 19:13:40 CST 2011


On Fri, Mar 4, 2011 at 4:13 AM, franck kalala
<franckkalala@googlemail.com> wrote:
>
> Hey all,
>
> I was install new release of scipy as describe here
> http://www.scipy.org/Installing_SciPy/Linux
>
> When I run the command
>
> python setup.py build
>
>
> I get at the end this error message
>
>
>
> swig: scipy/sparse/linalg/dsolve/umfpack/umfpack.i
> swig -python -I/usr/include/suitesparse -o
> build/src.linux-x86_64-2.6/scipy/sparse/linalg/dsolve/umfpack/_umfpack_wrap.c
> -outdir build/src.linux-x86_64-2.6/scipy/sparse/linalg/dsolve/umfpack
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i
>
>
>
> unable to execute swig: No such file or directory
> error: command 'swig' failed with exit status 1
>
> Any help with this?
>
Do you actually need UMFPACK? Some of those instructions are very
extensive, but UMFPACK and FFTW are not required for Scipy anymore.
You should also try to use pre-built ATLAS binaries from your
distribution or a third-party repository if you can.

Also, which linux are you using and what other steps did you follow
before "python setup.py build"?

Cheers,
Ralf


More information about the SciPy-User mailing list